UniServer 8.5.5-Coral - Mini Server Komplett Paket

alles was zum Hosten von Seiten gebraucht wird

Moderatoren: Jean, |Gordon|, Moderatoren

Benutzeravatar
likeatim
Gründer und Administrator
Beiträge: 2664
Registriert: 24.08.01, 13:01

UniServer 8.5.5-Coral - Mini Server Komplett Paket

Beitrag von likeatim » 15.05.03, 9:53

Hatte ich im CCB schon gepostet (mach ich hier hochmal im extra Thread, weil der UniServer imho aufgrund seiner Grösse unter den Serverpaketen schon raussticht ):

Also, um mal eben ein bisschen rumzucoden (z.B. ein Board offline laufen zu lassen), benutze ich den Uniform Server, der entpackt ca. 9 MB und als Installationspacket ganze 2,4 MB hat.

Hat alles, was man/ich brauche (Apache2, PHP 4, MySQL 4, PERL 5) und ist erhältlich unter
http://sourceforge.net/projects/miniserver/

Nettes Feature: Es wird ein virtuelles Laufwerk (per subst) angelegt, auf dem dann alle wichtigen Verzeichnisse (usr, home, www) sehr schnell und aufgeräumt erreichbar sind.

Tip: unter XP funktioniert die start.bat nicht so richtig (bei mir zumindest).
Ich benutze zum Starten daher lieber die (modifizierte) start.vbs, die bei mir wie folgt aussieht:
Dim WSHShell, dir, fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set WSHShell = WScript.CreateObject("WScript.Shell")
WSHShell.run "subst w: diskw ",0,0
' --- WSHShell.run "diskw\home\admin\program\start.bat",0,0
' --- If you wand to start the MySQL server automatically with the server - uncomment next line
WSHShell.run "w:\usr\local\apache2\bin\Apache.exe -f w:\usr\local\apache2\conf\httpd.conf -d w:\usr\local\apache2\.",0,0
WSHShell.run "w:\usr\local\mysql\bin\mysqld-opt.exe --defaults-file=my-small.cnf",0,0
' --- If you wand to open default browser at server start - uncomment next line
WSHShell.run "redirect.html"
Die stop.bat ist modifiziert ein sehr zuverlässiger one-click-beender aller Serverprozesse
@echo off
w:\home\admin\program\pv.exe -k -fq mysq*.exe
w:\home\admin\program\pv.exe -k -fq Apache.exe
subst w: /D
Zuletzt geändert von likeatim am 21.02.06, 14:03, insgesamt 1-mal geändert.

Jean
Beiträge: 11318
Registriert: 30.10.01, 12:41

Beitrag von Jean » 15.05.03, 14:21

ist ansonsten auch in Cabals Liste aller lieferbaren Webserver-Pakete zu finden.

Benutzeravatar
likeatim
Gründer und Administrator
Beiträge: 2664
Registriert: 24.08.01, 13:01

Beitrag von likeatim » 18.05.03, 22:11

hab ich doch geschrieben....
(mach ich hier hochmal im extra Thread, weil der UniServer imho aufgrund seiner Grösse unter den Serverpaketen schon raussticht ):

Jean
Beiträge: 11318
Registriert: 30.10.01, 12:41

Beitrag von Jean » 18.05.03, 23:57

habe ich ja auch gelesen - aber nach dem
Hinweis haben sicherlich viele Besucher nicht
hier, sondern im CCB gesucht :-)
Hatte ich im CCB schon gepostet ...

Benutzeravatar
TengriLethos
Beiträge: 267
Registriert: 15.06.02, 18:15

Beitrag von TengriLethos » 23.03.04, 14:27

neue Version 3.1 vom 6.3.2004:
- ActivePerl updated to 5.8.0.809;
- MySQL updated to 4.0.18;
- phpMyAdmin updated to 2.5.6;
- secure.pm allow from 127.0.0.1;
- bugfix in start.bat "subst /D";
- AddType Application/x-httpd-php-source .phps
Glauben ist eine relativ einfach vermeidbare Denkweise mit hohem Potential zur Fehleinschätzung der Wirklichkeit (2w'18)

losparasitos
Beiträge: 43
Registriert: 06.12.02, 3:34

probs mit uniserver

Beitrag von losparasitos » 24.03.04, 12:46

Moin ich habe mir mal den Uniserver installiert (aktuelle version) und muss sagen--->Echt ne coole Sache!!!

Ich habe allerdings ein kleines Problem mit dem Uniserver:

Ich möchte gern ein Dimension of phpBB Forum darüber laufen lassen (version 0.1.1 basiert auf phpBB2.07) allerdings habe ich folgendes prob:

Die Installation klappte hervorragend!!!!!
(Datenbank via phpMyAdmin erstellt, user erstellt-->global nur usage rechte datenbank spezifische rechte ALLE erhalten, dann hab ich das board in das vom uniserver erstellte laufwerk in das DIR www kopiert). Eigentlich funzt alles nur wenn ich in den Admin bereich will erhalte ich folgende Meldung:

Code: Alles auswählen

Fatal error: Cannot redeclare get_list() in W:\www\dim\admin\admin_kb_cat.php on line 31
Ich habe mir mal die admin_kb_cat.php angeschaut:
Line 31
function get_list($id, $select, $selected = false)
Ein ändern auf true brachte keine änderung

Es scheint als ob die Admin-Panels nicht funzen ähnliche fehler auch im JuniorAdmin.......... dewr MOD+VIP+Sponsor bereich funzt

Ansonsten funzt das board (habe nen user ohne probs registriert der sich auch einloggen, posten und am chat teilnehmen kann

Wäre cool wenn mir wer helfen kann!

phoibos
superqueruLaNd
Beiträge: 617
Registriert: 02.09.01, 22:17

Beitrag von phoibos » 24.03.04, 12:55

moin losparasitos,

ich kann dir leider nicht weiterhelfen und du bist hier dafür auch am falschen ort ;) das ist entweder ein phpbb-problem oder eines vom server und für beides gibt es spezialisierte support-foren. frag doch dort bitte noch mal nach...

ciao
phoibos

losparasitos
Beiträge: 43
Registriert: 06.12.02, 3:34

Beitrag von losparasitos » 24.03.04, 12:58

oki sorry, dachte mir evtl. kennt jemand das prob hier und hat ne Lösung parat.

Sollte ichs beseitigt haben poste ich (falls erwünscht) nen Workaround anyway thx

Benutzeravatar
likeatim
Gründer und Administrator
Beiträge: 2664
Registriert: 24.08.01, 13:01

Re: probs mit uniserver

Beitrag von likeatim » 24.03.04, 13:37

losparasitos hat geschrieben:Moin ich habe mir mal den Uniserver installiert (aktuelle version) und muss sagen--->Echt ne coole Sache!!!

Ich habe allerdings ein kleines Problem mit dem Uniserver:

Ich möchte gern ein Dimension of phpBB Forum darüber laufen lassen (version 0.1.1 basiert auf phpBB2.07) allerdings habe ich folgendes prob:

Die Installation klappte hervorragend!!!!!
(Datenbank via phpMyAdmin erstellt, user erstellt-->global nur usage rechte datenbank spezifische rechte ALLE erhalten, dann hab ich das board in das vom uniserver erstellte laufwerk in das DIR www kopiert). Eigentlich funzt alles nur wenn ich in den Admin bereich will erhalte ich folgende Meldung:

Code: Alles auswählen

Fatal error: Cannot redeclare get_list() in W:\www\dim\admin\admin_kb_cat.php on line 31
Ich habe mir mal die admin_kb_cat.php angeschaut:
Line 31
function get_list($id, $select, $selected = false)
Ein ändern auf true brachte keine änderung

Es scheint als ob die Admin-Panels nicht funzen ähnliche fehler auch im JuniorAdmin.......... dewr MOD+VIP+Sponsor bereich funzt

Ansonsten funzt das board (habe nen user ohne probs registriert der sich auch einloggen, posten und am chat teilnehmen kann

Wäre cool wenn mir wer helfen kann!
  1. admin_kb_cat.php muss von einem MOD stammen, ist nicht phpbb standard
  2. du musst in der config.php wahrscheinlich auf mysql4 umstellen, der Uniserver hat die drin, nicht mehr die 3er
  3. der Uniserver läuft mit Apache2, den phpBB noch nicht vollständig unterstützt
Ich würde das Ding eher auf dem Paket von dpaehl laufen lassen (such ma hier im Board), das noch Apache 1.3 und MySQL 3.x enthält!

losparasitos
Beiträge: 43
Registriert: 06.12.02, 3:34

Beitrag von losparasitos » 24.03.04, 14:48

danke likeatim!!!!!

du hast recht ich benutzte ein gemoddetes phpBB, und das mit mysql4 scheint auch zu stimmen (es war richtig in der config.php eingetragen) mit dem paket2 von dpaehl ist das prob wech (allerdings jetzt nen neues, welches aber net tragisch sein dürfte, er findet keinen http: referer dürfte aber auch auf localhost nicht der fall sein..... oder?).

Mal sehen ob das Mod Team von Dimesion of phpBB evtl. hilfe in ihren support foren bietet.

Benutzeravatar
TengriLethos
Beiträge: 267
Registriert: 15.06.02, 18:15

Beitrag von TengriLethos » 30.07.04, 15:19

(endlich;-) das Update auf 3.2 mit PHP5.0 u.a.:

3.2 - Apache updated to 2.0.50;
- PHP updated to 5.0.0;
- MySQL updated to 4.0.20d;
- ActivePerl updated to 5.8.0.810;
- phpMyAdmin updated to 2.6.0-beta2;
- PHP GD2,mysql and sockets extentions included;
- Script to convert server to NTservices works again;
- Turck MMCache removed;
- core server arcitecture improved;
...
Das Paket hat auch im Umfang durchaus zulegt(von 2.6MB auf 3.7MB) aber es ist ja immer noch sehr schlank im Vergleich zu anderen, die sich die Wampe vollgehauen haben...
Glauben ist eine relativ einfach vermeidbare Denkweise mit hohem Potential zur Fehleinschätzung der Wirklichkeit (2w'18)

Benutzeravatar
TengriLethos
Beiträge: 267
Registriert: 15.06.02, 18:15

Beitrag von TengriLethos » 01.07.05, 12:49

Die Version 3.3 lässt noch auf sich warten, aber es gibt eine 3.2a (vom 16.06.2005) unter
http://sourceforge.net/forum/forum.php?forum_id=474437
3.2a - Apache updated to 2.0.54;
- PHP updated to 5.0.4;
- MySQL updated to 4.1.12a;
- ActivePerl updated to 5.8.7.813;
- phpMyAdmin updated to 2.6.3-rc1;
Glauben ist eine relativ einfach vermeidbare Denkweise mit hohem Potential zur Fehleinschätzung der Wirklichkeit (2w'18)

HICO
Beiträge: 23
Registriert: 27.05.02, 20:36

Beitrag von HICO » 30.12.05, 21:22

Neue Version von meinem Lieblings Webserver erschienen unter http://www.uniformserver.com/index.php

Finde leider keinen Changelog

Benutzeravatar
TengriLethos
Beiträge: 267
Registriert: 15.06.02, 18:15

Beitrag von TengriLethos » 21.02.06, 14:01

Der Updatehinweis von HICO ist leider etwas untergegangen. Aktuell ist also die Version 3.3, das Changelog ist unter http://doc.uniformserver.com/changes.html versteckt und beinhaltet im Wesentlichen:
- PHP & PHP Extensions updated to 5.1.1;
- MySQL updated to 5.1.17;
- Apache updated to 2.0.55;
- ActivePerl updated to 5.8.7.815;
- phpMyAdmin updated to 2.6.4-pl4;
- phpMyBackupPro Added - 1.7.1
- New Admin Panel 2.0 - Alpha Release;
...
Glauben ist eine relativ einfach vermeidbare Denkweise mit hohem Potential zur Fehleinschätzung der Wirklichkeit (2w'18)

hylli
Mitglied
Beiträge: 1741
Registriert: 05.04.06, 13:56

Beitrag von hylli » 16.10.07, 19:05

Mittlerweile bei Version 3.5!

Changelog:
3.5 - phpMyAdmin updated to 2.10.2;
- Admin Panel 2.0 Updated;
- Service Scripts Updated/Bug Fixes;
- MySQL Priv Bug Fix
- core server arcitecture/structure updated;
...

3.4 - phpMyAdmin updated to 2.10.1;
- eAccelerator 0.9.5.1 + Control Panel
- MySQL updated to 5.0.41;
- Apache updated to 2.0.59;
- PHP & PHP Extensions updated to 5.2.3;
- ActivePerl updated to 5.8.8.820;
- phpMyBackupPro updated to - 2.1;
- Admin Panel 2.0 Updated;
- Service Scripts Updated/Bug Fixes;
- Scroller Fixed/Removed
- core server arcitecture/structure updated;
...
Hylli

wiegmann
Mitglied
Beiträge: 396
Registriert: 31.08.07, 10:42

Beitrag von wiegmann » 04.04.09, 17:48


bollino
Mitglied
Beiträge: 520
Registriert: 15.04.05, 9:31

Beitrag von bollino » 21.05.09, 21:20

Uniform Server 4.2-Mona May 20, 2009

http://forum.uniformserver.com/index.php?showtopic=1665
This release of Mona is an upgrade to the core components either because of stability or security issues.

Specification changes:
- MySQL updated to 5.1.34;
- PHP security update 5.2.9-2;
- eAccelerator updated to 0953_5.2.9.2
- few minor corrections;

Unless there are serious bugs, significant changes to the core components (bugs) or security updates this is the last in the Mona series. Any further releases will be maintenance only.
bo*

bollino
Mitglied
Beiträge: 520
Registriert: 15.04.05, 9:31

Beitrag von bollino » 15.07.09, 0:35

This Account Has Been Suspended
Please contact the billing/support department as soon as possible.
??? Zu viel Traffic, oder ???

Auf jeden Fall dicht.

Bo*

Benutzeravatar
Gordon
Beiträge: 13260
Registriert: 06.01.02, 18:46

Beitrag von Gordon » 15.07.09, 7:11

bollino hat geschrieben:
This Account Has Been Suspended
Please contact the billing/support department as soon as possible.
??? Zu viel Traffic, oder ???

Auf jeden Fall dicht.

Bo*
nur http://www.uniformserver.com/ ist weg, auf SF gibt es auch die neue Version 4.3
Changes:
4.3 - MySQL updated to 5.1.35;
- PHP security update 5.2.10;
- phpMyAdmin updated to 3.2.0;
- eAccelerator updated to 0953_5.2.10
DL: http://sourceforge.net/projects/miniserver/
Freude ist nur ein Mangel an Information.

Benutzeravatar
rothom
Mitglied
Beiträge: 121
Registriert: 08.08.04, 18:10

Beitrag von rothom » 12.08.09, 11:25

SF wartet schon mit der Version 5.0 (beta) auf:

D/L:

http://sourceforge.net/projects/miniserver/files/

C/L:
Changes:
5.0 - Apache updated to 2.2.12;
- MySQL updated to 5.1.37;
- phpMyAdmin updated to 3.2.0.1;
- PHP updated to 5.3.0;
- ActivePerl updated to 5,10,0,1005 Plugin;
- Integrated UniTray;
- eAccelerator - 0.9.6-rc1
- Major Architecture change;

...
Ausführliche Beschreibung zur neuen Version:
http://sourceforge.net/userapps/mediawi ... troduction

Gruß
rothom


Gruß
rothom

Antworten